Sauce Labs Maintenance Windows for Sauce Labs
Customers may experience intermittent errors during automated browser and virtual mobile device tests in our US-West-1 datacenter. We are closely monitoring and investigating the affected services.
2022-June-22 Resolved Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Wednesday June 22nd 2022, 14:55 - 18:02 UTC

What happened:

During a deployment we introduced a bug that caused all Live Cross Browser Desktop sessions to fail for macOS. The users were presented with a “loading” screen and the session never started. 

Why it happened:

A deployment of our web UI component introduced an uncaught exception leading to sessions not starting for macOS. 

How we fixed it:

We rolled back the web UI to the previous known good version. 

What we are doing to prevent it from happening again:

We are addressing the bug that was introduced in this release. We are adding additional testing to verify all session types will start after a release.

Posted Jun 27, 2022 - 14:50 UTC

Resolved
Between 13:30 UTC and 18:36 UTC, we experienced issues starting Mac OS Live tests via the Sauce Labs Dashboard in all of our Data Centers. This issue is now resolved. All services are fully operational.
Posted Jun 22, 2022 - 18:30 UTC