Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs has consolidated onto one status page for all data centers.

The old status pages for US-West, US-East and EU-Central are still available to be able to view incident history. Anyone who was subscribed to notifications from one of the old status pages has been migrated onto this consolidated page. If you received an email saying that you had been unsubscribed from notifications, that was from one of the old pages and can be disregarded.

If you would like to select which components that you receive notifications for (e.g. if you are only interested in receiving notifications about incidents affecting Real Device Testing), you can access the subscription management page by clicking "Subscribe To Updates" above and enter the email address you are subscribed with. Additionally there is a "Manage Your Subscription" link on any email you will receive from the status page going forward.
2021-May-05 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Wednesday, May 05, 06:09 - 09:59 AM UTC

What happened:

Sauce Connect tunnels for the Legacy RDC platform in our EU data center would not start.

Why it happened:

A server hosting Sauce Connect components was power cycled and restarted with a faulty DNS configuration. A load balancer didn't recognize that the instance was faulty and continued to serve traffic to it.

How we fixed it:

We fixed the faulty DNS configuration which caused the instance to recover.

What we are doing to prevent it from happening again:

We are updating all DNS configurations for the affected cluster to make sure this problem doesn't occur again. In addition, we will improve the health check for this service to make sure we detect faulty instances properly and stop sending traffic to them.

Posted May 10, 2021 - 17:26 UTC

Resolved
This incident has been resolved. All services are operational.
Posted May 05, 2021 - 09:59 UTC
Update
We are continuing to investigate this issue.
Posted May 05, 2021 - 08:42 UTC
Investigating
Legacy RDC Sauce Connect tunnels in our EU Datacenter are not starting. Unified Platform Sauce Connect tunnels are not affected. We are investigating.
Posted May 05, 2021 - 07:32 UTC
This incident affected: Sauce Connect (Legacy RDC) (EU-Central).