Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs has consolidated onto one status page for all data centers.

The old status pages for US-West, US-East and EU-Central are still available to be able to view incident history. Anyone who was subscribed to notifications from one of the old status pages has been migrated onto this consolidated page. If you received an email saying that you had been unsubscribed from notifications, that was from one of the old pages and can be disregarded.

If you would like to select which components that you receive notifications for (e.g. if you are only interested in receiving notifications about incidents affecting Real Device Testing), you can access the subscription management page by clicking "Subscribe To Updates" above and enter the email address you are subscribed with. Additionally there is a "Manage Your Subscription" link on any email you will receive from the status page going forward.
2021-February-22 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Monday, February 22, 2021, 15:30 - 16:50 PST

What happened:

Customers were unable to start Mac desktop browser tests and iOS Simulator tests in the EU datacenter.

Why it happened:

The primary link to the Mac cloud went into a maintenance window and the connection was not successfully failed over to the secondary link.

How we fixed it:

The connection was manually failed over to the secondary link.

What are we doing to prevent it from happening again:

The fail-over configuration has been updated to catch additional scenarios which will lead to successful hand-off in future cases where the primary link becomes unusable.

Posted Feb 24, 2021 - 21:37 UTC

Resolved
macOS and iOS tests are back to normal. All services fully operational.
Posted Feb 23, 2021 - 01:24 UTC
Update
We have taken remedial action and see MacOS and iOS tests starting successfully. We are monitoring
Posted Feb 23, 2021 - 01:11 UTC
Update
Tests are continuing to fail, your iOS simulator and desktop tests may not start. We are continuing to monitor and investigate.
Posted Feb 23, 2021 - 00:47 UTC
Monitoring
We have taken remedial actions. We are monitoring but Mac iOS simulator and desktop tests should be fully operational.
Posted Feb 23, 2021 - 00:31 UTC
Update
We are continuing to investigate this issue.
Posted Feb 23, 2021 - 00:23 UTC
Investigating
The Mac cloud is experiencing errors, iOS simulator tests and Mac Desktop tests will not start. We are investigating and taking remedial action.
Posted Feb 23, 2021 - 00:16 UTC
This incident affected: Live Virtual Mobile Device Testing (EU-Central), Live Browser Testing (EU-Central), Automated Virtual Mobile Device Testing (EU-Central), and Automated Browser Testing (EU-Central).