Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs will have a four hour previously scheduled maintenance window on Wednesday, July 10th, starting at 04:00 UTC and ending at 08:00 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our US West data center. These maintenance actions may cause portions of the service (including running automated and manual tests) to be unavailable for up to four hours.
2024-June-7 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Friday June 7 2024, 12:16 - 13:54 UTC

What happened:

SC4 tunnels were intermittently not starting in US-WEST.

Why it happened:

An unexpected, intermittent DNS resolution failure began occurring after upgrading a hypervisor on which the primary DNS server was running.

How we fixed it:

We repaired the primary DNS server and returned it back to service. 

What we are doing to prevent it from happening again:

We’re evaluating an alternative DNS deployment.

Posted Jun 25, 2024 - 03:48 UTC

Resolved
After taking remedial action, Sauce Connect 4 tunnels are starting successfully in our US-West data center. All services are fully operational.
Posted Jun 07, 2024 - 13:56 UTC
Monitoring
We have fixed the root cause, and Sauce Connect 4 tunnels are starting successfully in our US-West data center. We are monitoring.
Posted Jun 07, 2024 - 13:52 UTC
Identified
We have identified the root cause and are working on implementing a fix.
Posted Jun 07, 2024 - 13:40 UTC
Investigating
Sauce Connect 4 tunnels are intermittently failing to start in our US-West data center. We are investigating.
Posted Jun 07, 2024 - 12:52 UTC
This incident affected: Sauce Connect (US-West).