Sauce Labs Maintenance Window
We are experiencing intermittent issues with iOS Simulators and MacOS desktop browser tests in our US-West data center, caused by a third-party service disruption. Our engineering team is actively coordinating with the provider to restore full service.

2026-April-07 Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Monday April 7th 2026, ~11:00 – 15:55 UTC

What happened:

Some customers experienced 503 errors when running tests via saucectl. The test-composer service was intermittently unavailable, preventing framework-based test execution.

Why it happened:

A stale Docker image was deployed to the test-composer service due to a packaging issue that arose during an internal container registry migration. This caused service pods to crash.

How we fixed it:

We identified the stale image and redeployed the correct version, restoring the service.

What we are doing to prevent it from happening again:

We are hardening our image deployment pipeline and adding validation checks to ensure container registry migrations do not result in stale or incorrect images being deployed to production.

Posted Apr 10, 2026 - 21:58 UTC

Resolved

We have identified the root cause and have deployed a fix for this issue. All services are fully operational.
Posted Apr 07, 2026 - 16:13 UTC

Investigating

We are currently investigating reports of test failures affecting users running tests using SauceCtl in our US-West-1 and EU-Central-1 Data Center. We are investigating.
Posted Apr 07, 2026 - 15:02 UTC
This incident affected: Automated Browser Testing (US-West, EU-Central), Automated Virtual Mobile Device Testing (US-West, EU-Central), Automated Real Device Testing (US-West, EU-Central), and Native Framework Mobile App Testing (US-West, EU-Central).