Sauce Labs Maintenance Windows for Sauce Labs
Customers may experience intermittent errors during automated browser and virtual mobile device tests in our US-West-1 datacenter. We are closely monitoring and investigating the affected services.
2024-March-6 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Wednesday March 6th 2024, 12:43 - 19:00 UTC

What happened:

Test artifact uploads and downloads intermittently failed or were slower to complete, resulting in issues displaying test results.

Why it happened:

A subsystem involved in artifact uploads would not properly recover from some failures, resulting in leaked connections and connection pool exhaustion.  Once fully exhausted, uploads were no longer possible.

How we fixed it:

We identified the bug in the code and deployed a fix.

What we are doing to prevent it from happening again:

We have fixed the specific bug and implemented monitoring for similar symptoms.

Posted Apr 09, 2024 - 14:14 UTC

Resolved
This incident has been resolved.
Posted Mar 06, 2024 - 19:37 UTC
Investigating
We are currently experiencing intermittent issues loading real device test reports on the dashboard in our US West Data Center. We are investigating.
Posted Mar 06, 2024 - 19:03 UTC
This incident affected: Automated Real Device Testing (US-West), Live Real Device Testing (US-West), and Native Framework Mobile App Testing (US-West).