Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs will have a four hour previously scheduled maintenance window on Wednesday, July 10th, starting at 04:00 UTC and ending at 08:00 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our US West data center. These maintenance actions may cause portions of the service (including running automated and manual tests) to be unavailable for up to four hours.
2024-May-3 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Thursday May 3 2024, 10:36 - 12:02 UTC

What happened:

There was limited access to the Sauce Labs UI for customers in our “US East 4” datacenter. 

Why it happened:

A renewed SSL certificate was not applied properly.

How we fixed it:

The certificate was applied correctly. 

What we are doing to prevent it from happening again:

We have improved our certificate expiration monitoring for this environment.

Posted May 23, 2024 - 10:02 UTC

Resolved
After taking remedial action, access to the dashboard and manual testing in our US-East-4 datacenter has been restored. This incident is resolved.
Posted May 03, 2024 - 12:08 UTC
Investigating
We are currently experiencing an issue accessing our web application in the US-East-4 datacenter, this affects access to the Sauce Labs dashboard and manual testing. We are investigating.
Posted May 03, 2024 - 11:48 UTC
This incident affected: Live Real Device Testing (US-East).