Sauce Labs Maintenance Windows for Sauce Labs
We are currently performing maintenance that will affect the initiation of new Sauce Connect tunnel instances. The maintenance is expected to be completed by 2:00 PM PST. We appreciate your understanding and patience as we work to enhance our service.

2023-April-12 Resolved Service Incident

Incident Report for Sauce Labs

Postmortem

Posted May 17, 2023 - 10:26 UTC

Resolved

Between 00:30 - 08:00 UTC, we were experiencing elevated wait times for tests in our US-West-1 data center, we have identified the issue and taken remedial action.
Posted Apr 11, 2023 - 23:30 UTC