Sauce Labs Maintenance Windows for Sauce Labs
We are currently aware of an ongoing issue impacting the Talkback functionality on our Real Device Cloud. Our team is actively working to resolve this as quickly as possible.
2025-January-7 Service Incident
Incident Report for Sauce Labs
Resolved
Access to *.testfairy.com via Chromium-based browsers has been restored. This incident is resolved.
Posted Jan 07, 2025 - 18:09 UTC
Update
There is currently an intermittent issue with accessing *.testfairy.com pages via Chromium-based browsers, preventing app distribution. Safari browsers can still access these sites. We are investigating.
Posted Jan 07, 2025 - 10:58 UTC
Update
There is currently an issue with accessing *.testfairy.com pages via Chromium-based browsers, preventing app distribution. Safari browsers can still access these sites. We are investigating.
Posted Jan 07, 2025 - 09:36 UTC
Investigating
We are currently seeing .testfairy.com Website pages throwing full-page red alert error messages. We are investigating.
Posted Jan 07, 2025 - 09:12 UTC
This incident affected: Mobile App Distribution (TestFairy) (TestFairy Platform, TestFairy UI).