Sauce Labs Partially Degraded Service
We are currently experiencing a slight reduction in available public and private iOS devices in the EU-Central Data Center. We expect to restore full availability for all iOS users in the EU-Central Data Center by tomorrow, Thursday, July 3, 2025, end of day

2025-April-2 Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Tuesday April 1st 2025, 14:54 UTC - Wednesday April 2nd 2025, 13:45 UTC

What happened:

iOS tests using Sauce Connect failed to start.

Why it happened:

There was a mismatch in the SSL certificate's expiration dates.

How we fixed it:

Re-ordered new SSL certificates.

What we are doing to prevent it from happening again:

We are adding monitoring for the SSL certificates.

Posted May 17, 2025 - 10:48 UTC

Resolved

After taking remedial action, all services are operating as normal. This incident is resolved.
Posted Apr 02, 2025 - 15:23 UTC

Monitoring

We have identified the root cause and have deployed a fix for this issue. We are monitoring.
Posted Apr 02, 2025 - 13:48 UTC

Update

We are continuing to see iOS simulator test failures when using Sauce Connect in the US-West-1 & EU-Central-1 Data Centers. We are actively investigating.
Posted Apr 02, 2025 - 11:03 UTC

Investigating

We are seeing failing iOS simulator tests when using Sauce Connect in US-West-1 & EU-Central-1 Data Centers. We are investigating.
Posted Apr 02, 2025 - 09:53 UTC
This incident affected: Automated Virtual Mobile Device Testing (US-West, EU-Central) and Live Virtual Mobile Device Testing (US-West, EU-Central).