Sauce Labs Maintenance Windows for Sauce Labs
We are aware of and working to resolve intermittent WiFi connectivity and slowness issues affecting Android Real Devices in our US-West-1 data center. During a maintenance window on September 25, we made changes to our wireless infrastructure which has greatly improved the situation, but we are still monitoring and working on further improvements. Please contact our Support team should you wish to report any such issues.

2021-Dec-07 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Tuesday December 7th 2021, 7:30 - 8:30 UTC

What happened:

Visual Testing services, including the Visual Testing UI, were unavailable and tests failed to start.

Why it happened:

Unanticipated side effects of some database maintenance caused database connections to drop.

How we fixed it:

Services were able to reconnect once the database maintenance was complete. 

What we are doing to prevent it from happening again:

We are working to understand the possible risk of future maintenance and will perform this work during scheduled maintenance windows if necessary.

Posted Dec 11, 2021 - 12:35 UTC

Resolved
This incident has been resolved.
Posted Dec 07, 2021 - 08:35 UTC
Monitoring
Visual services are recovering and new builds are now running correctly. Builds that were started whilst services were impacted will timeout. We are continuing to monitor the situation.
Posted Dec 07, 2021 - 08:18 UTC
Investigating
Our Visual Testing service is unavailable. We are investigating.
Posted Dec 07, 2021 - 07:55 UTC
This incident affected: Visual Testing Hub, Visual Testing Infrastructure, Visual Testing REST API, and Visual Testing (Screener) UI.