Sauce Labs Maintenance Windows for Sauce Labs
We are currently performing maintenance that will affect the initiation of new Sauce Connect tunnel instances. The maintenance is expected to be completed by 2:00 PM PST. We appreciate your understanding and patience as we work to enhance our service.

2023-October-4 Service Incident

Incident Report for Sauce Labs

Postmortem

Posted Oct 23, 2023 - 12:07 UTC

Resolved

iOS and Android real device tests in the US West and EU Central datacenters are running with no further timeout errors. All services are fully operational.
Posted Oct 04, 2023 - 18:35 UTC

Monitoring

We have fixed the root cause, and all real device tests are running successfully in our US West data center. We are monitoring.
Posted Oct 04, 2023 - 13:31 UTC

Identified

We have identified the root cause and we are implementing a fix. Currently there is no impact on real device testing in our US West data center.
Posted Oct 04, 2023 - 10:42 UTC

Update

After taking remedial action iOS and Android real device tests are running successfully in the US West data center. We are working on identifying the root cause.
Posted Oct 04, 2023 - 09:05 UTC

Investigating

We are seeing an increase in timeouts when running iOS and Android real device tests in the US West data center. We are investigating.
Posted Oct 04, 2023 - 08:27 UTC
This incident affected: Automated Real Device Testing (US-West) and Native Framework Mobile App Testing (US-West).