We are experiencing an intermittent issue in our US-West-1 datacenter that causes elevated wait times and error rates when starting desktop browser and virtual mobile device tests. Until we address the underlying causes of this issue, we expect this issue to continue to reoccur. We will post incidents here on our status page as each instance of this issue occurs whilst we continue to work to address the underlying cause.
Get email notifications whenever Sauce Labs creates, updates or resolves an incident.
Get text message notifications whenever Sauce Labs creates or resolves an incident.
Get incident updates and maintenance status messages in Slack.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 25, 2022 - 17:00 UTC
Scheduled
Sauce Labs will have a two hour previously scheduled maintenance window on June 25th, starting at 17:00 UTC and ending at 19:00 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our EU data center. These maintenance actions may cause portions of the service (including running automated and manual tests) to be unavailable for up to two hours.
Posted Apr 29, 2022 - 11:43 UTC
This scheduled maintenance affected: Automated Virtual Mobile Device Testing (EU-Central), Automated Real Device Testing (EU-Central), Live Browser Testing (EU-Central), Live Virtual Mobile Device Testing (EU-Central), Live Real Device Testing (EU-Central), IPSec VPN (EU-Central), Native Framework Mobile App Testing (EU-Central), API Testing (EU-Central), Automated Browser Testing (EU-Central), Sauce Connect (EU-Central), and Sauce Labs REST API (EU-Central).