Sauce Labs Maintenance Windows for Sauce Labs
We are aware of and working to resolve intermittent WiFi connectivity and slowness issues affecting Android Real Devices in our US-West-1 data center. During a maintenance window on September 25, we made changes to our wireless infrastructure which has greatly improved the situation, but we are still monitoring and working on further improvements. Please contact our Support team should you wish to report any such issues.

2021-October-18 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Monday October 18th 2021, 16:00 - 16:45 UTC

What happened:

Live tests running in our US West data center on Android devices were receiving intermittent "device disconnected" messages.

Why it happened:

Due to a degradation in performance of our RDC system, connectivity from a certain number of devices was failing.

How we fixed it:

The performance improved automatically within ~30 minutes.

What we are doing to prevent it from happening again:

We are closely monitoring our real device systems for increments in errors and changes in performance.

Posted Oct 26, 2021 - 08:09 UTC

Resolved
After investigation, we are seeing devices start up as normal and not get disconnected. All services are fully operational.
Posted Oct 18, 2021 - 17:02 UTC
Investigating
We have received reports of Android devices getting "device disconnected" errors when navigating via Live Testing on our US West data center. We are investigating
Posted Oct 18, 2021 - 16:21 UTC
This incident affected: Live Real Device Testing (US-West).