Sauce Labs Maintenance Window
We are currently experiencing a slight reduction in available public and private iOS devices in the EU-Central Data Center. We expect to restore full availability for all iOS users in the EU-Central Data Center by tomorrow, Thursday, July 3, 2025, end of day

2022-June-07 Service Incident

Incident Report for Sauce Labs

Resolved

After taking remedial action the Sauce Labs dashboard for our US-West-1 datacenter is now loading successfully.
Posted Jun 07, 2022 - 15:51 UTC

Investigating

The Sauce Labs dashboard for our US-West-1 datacenter (https://app.saucelabs.com) is intermittently returning 404 errors. We are investigating.
Posted Jun 07, 2022 - 14:44 UTC
This incident affected: Sauce Labs Dashboard (US-West).