Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs will have a four hour previously scheduled maintenance window on Wednesday, July 10th, starting at 04:00 UTC and ending at 08:00 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our US West data center. These maintenance actions may cause portions of the service (including running automated and manual tests) to be unavailable for up to four hours.
2024-April-17 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Monday April 17th 2024, 15:50 - 16:55 UTC

What happened:

Automated and live tests for virtual and real device clouds in the US West region failed.

Why it happened:

An invalid configuration was deployed that prevented connections from being accepted.  Additionally, following the change being reverted, an internal component was unable to appropriately handle the sudden surge in traffic.

How we fixed it:

We rolled back the configuration to the previous version and restarted an internal service.

What we are doing to prevent it from happening again:

We are evaluating strategies for more rapidly scaling the affected internal service.

Posted May 14, 2024 - 18:06 UTC

Resolved
After taking remedial action, all services are operating as normal. This incident is resolved.
Posted Apr 17, 2024 - 17:08 UTC
Update
We are continuing to investigate this issue.
Posted Apr 17, 2024 - 17:07 UTC
Update
We are continuing to investigate this issue.
Posted Apr 17, 2024 - 16:49 UTC
Investigating
We are aware of reports of intermittent errors when attempting to start automated and live tests in our US-West-1 data center. We are investigating.
Posted Apr 17, 2024 - 16:44 UTC
This incident affected: Automated Browser Testing (US-West), Automated Virtual Mobile Device Testing (US-West), Automated Real Device Testing (US-West), Live Browser Testing (US-West), Live Virtual Mobile Device Testing (US-West), Live Real Device Testing (US-West), and Native Framework Mobile App Testing (US-West).