Sauce Labs Maintenance Windows for Sauce Labs
We are currently performing maintenance that will affect the initiation of new Sauce Connect tunnel instances. The maintenance is expected to be completed by 2:00 PM PST. We appreciate your understanding and patience as we work to enhance our service.

2024-November-19 Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Wednesday November 19th 2024, 21:30 - 23:30 UTC

What happened:

Android real devices were unable to run app tests in all datacenters.

Why it happened:

An unexpected policy change by Google caused MDM managed devices to be locked down due to policy violations around accessibility services.

How we fixed it:

We rolled back enablement of the TalkBack accessibility service.

What we are doing to prevent it from happening again:

We opened a support case with Google to get further information on why this policy change happened, as well as began investigating running our own MDM solution.

Posted 7 days ago. Apr 01, 2025 - 15:58 UTC

Resolved

After taking remedial action all services are operating as normal. This incident is resolved.
Posted 5 months ago. Nov 19, 2024 - 22:28 UTC

Investigating

Android real devices in US West 1, EU Central 1, and US East datacenter are unable to run automated Appium and Espresso app tests and manual app tests. We are investigating.
Posted 5 months ago. Nov 19, 2024 - 21:35 UTC
This incident affected: Automated Real Device Testing (US-West, EU-Central, US-East), Live Real Device Testing (US-West, EU-Central, US-East), and Native Framework Mobile App Testing (US-West, EU-Central, US-East).