We are investigating an issue with a third-party provider that is causing intermittent "Connection timed out", "pool communication" and "Unknown error while proxying appium request" errors when running tests in our EU and US datacenters. We will be performing emergency maintenance to our EU-Central and US-West datacenters this week to address this issue. Emergency maintenance windows will be posted to this page.
Get email notifications whenever Sauce Labs creates, updates or resolves an incident.
Get text message notifications whenever Sauce Labs creates or resolves an incident.
Get incident updates and maintenance status messages in Slack.
After taking remedial action, we are seeing normal wait times and the error rates during session creation have subsided for desktop and virtual mobile device tests. This issue is resolved
Posted Feb 03, 2023 - 04:25 UTC
Update
After taking remedial action, we are seeing normal wait times and the error rates during session creation have subsided for desktop and virtual mobile device tests. We are currently monitoring.
Posted Feb 03, 2023 - 03:31 UTC
Monitoring
After taking remedial action, we are seeing normal wait times and the error rates during session creation have subsided for desktop and virtual mobile device tests. This incident is resolved.
Posted Feb 03, 2023 - 03:27 UTC
Update
We are continuing to investigate this issue.
Posted Feb 03, 2023 - 03:00 UTC
Investigating
Desktop and virtual mobile device tests are receiving long wait times and a high rate of errors upon session start. This includes MacOS desktop, Windows desktop, Android emulator tests, and iOS simulator tests. We are investigating.
Posted Feb 03, 2023 - 02:59 UTC
This incident affected: Automated Browser Testing (US-West, EU-Central), Automated Virtual Mobile Device Testing (US-West, EU-Central), Live Browser Testing (US-West, EU-Central), and Live Virtual Mobile Device Testing (US-West, EU-Central).