Sauce Labs Maintenance Windows for Sauce Labs
Customers may experience intermittent errors during automated browser and virtual mobile device tests in our US-West-1 datacenter. We are closely monitoring and investigating the affected services.
2022-August-12 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Friday August 12th 2022, 12:00 - 14:03 UTC

What happened:

Customers were unable to log into app.saucelabs.com due to an expired certificate. 

Why it happened:

During our normal practice of renewing certificates, we missed a location that impacted our web frontend. Most of our certificates are applied through automation except a few locations like this one which reside on a CDN that we are in the process of deprecating. 

How we fixed it:

We manually updated the certificates and users were able to access the web frontend again. 

What we are doing to prevent it from happening again:

We are removing the CDN where these certificates are applied in favor of one in GCP where we have automation and better monitoring of certificate expiry.

Posted Aug 22, 2022 - 11:40 UTC

Resolved
After taking remedial action access to the Sauce Labs platform UI has been fully restored.
Posted Aug 12, 2022 - 14:04 UTC
Monitoring
After taking remedial action access to the Sauce Labs platform UI has been partially restored. We are monitoring.
Posted Aug 12, 2022 - 13:24 UTC
Investigating
The Sauce Labs platform UI is currently down. We are investigating.
Posted Aug 12, 2022 - 12:52 UTC
This incident affected: Sauce Labs Dashboard (US-West, EU-Central).