Sauce Labs Maintenance Windows for Sauce Labs
We are currently performing maintenance that will affect the initiation of new Sauce Connect tunnel instances. The maintenance is expected to be completed by 2:00 PM PST. We appreciate your understanding and patience as we work to enhance our service.

2024-October-11 Resolved Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Friday October 11 2024, 04:30 - 04:57 UTC

What happened:

Real Devices in our US East 4 datacenter were unavailable due to a lack of internet connectivity at the site.

Why it happened:

Both network providers used by the US East datacenter were down.

How we fixed it:

One of the network providers restored service, allowing RDC devices to become available.

What we are doing to prevent it from happening again:

Our Network team is looking into alternate IP transit providers to improve reliability.

Posted Apr 01, 2025 - 15:36 UTC

Resolved

Between 04:30 and 04:57 UTC, we were experiencing elevated error rates and reduced device availability for Real device tests in our US-East data center. The issue is now resolved. All services are fully operational.
Posted Oct 11, 2024 - 05:00 UTC