Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs has consolidated onto one status page for all data centers.

The old status pages for US-West, US-East and EU-Central are still available to be able to view incident history. Anyone who was subscribed to notifications from one of the old status pages has been migrated onto this consolidated page. If you received an email saying that you had been unsubscribed from notifications, that was from one of the old pages and can be disregarded.

If you would like to select which components that you receive notifications for (e.g. if you are only interested in receiving notifications about incidents affecting Real Device Testing), you can access the subscription management page by clicking "Subscribe To Updates" above and enter the email address you are subscribed with. Additionally there is a "Manage Your Subscription" link on any email you will receive from the status page going forward.
2021-February-10 Resolved Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Wednesday, February 10, 2021, 01:00 - 08:00 PST 

What happened:

Customers may have experienced 401 and CORS errors when logging into the Sauce Labs dashboard from regions within the U.S.. 

Why it happened:

A server that had been drained was still being used by the load balancer managing the sign in process.

How we fixed it:

The issue was resolved once the load balancer stopped using the drained server.

What we are doing to prevent it from happening again:

We reconfigured the affected load balancer to more rapidly cease use of any drained servers.

Posted Feb 24, 2021 - 21:35 UTC

Resolved
Between 1am PST and 8am PST login attempts may have been slow or ended in a 401 Clearance Needed error page.
Posted Feb 10, 2021 - 09:30 UTC