Sauce Labs Maintenance Window
We are experiencing intermittent issues with iOS Simulators and MacOS desktop browser tests in our US-West data center, caused by a third-party service disruption. Our engineering team is actively coordinating with the provider to restore full service.

2026-March-10 Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Tuesday March 10th 2026, 17:52 - 23:34 UTC

What happened:

The majority of iOS devices across all regions became unavailable.

Why it happened:

Apple's ppq.apple.com app verification endpoint was down, causing internal device monitoring checks to fail, bringing devices offline.

How we fixed it:

We temporarily disabled these device monitoring checks.

What we are doing to prevent it from happening again:

Improved external monitoring to catch outages of apple’s ppq.apple.com endpoint, loosened device monitoring to not take down live iOS devices if ppq.apple.com is down.

Posted Apr 10, 2026 - 18:54 UTC

Resolved

This incident has been resolved.
Posted Mar 10, 2026 - 23:34 UTC

Investigating

We are experiencing device unavailability in the US West 1, EU Central 1, and US East 4 data centers and have found that the issue is caused by a 3rd party service disruption. We are investigating.
Posted Mar 10, 2026 - 18:46 UTC
This incident affected: Automated Real Device Testing (US-West, EU-Central, US-East) and Live Real Device Testing (US-West, EU-Central, US-East).