Sauce Labs Maintenance Windows for Sauce Labs
Customers may experience intermittent errors during automated browser and virtual mobile device tests in our US-West-1 datacenter. We are closely monitoring and investigating the affected services.
2022-August-4 Resolved Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Thursday August 4th 2022, 14:17 - 14:24 UTC

What happened:

Sauce Connect tunnels were failing and our dashboard was unresponsive in our US-West-1 region due to an issue with our user authentication service. 

Why it happened:

A release for the user authentication service was deployed in order to address a performance issue. This deployment introduced some unexpected behavior that interfered with requests to it. 

How we fixed it:

We rolled back the release to the prior version. 

What we are doing to prevent it from happening again:

We are continuing our investigation into the performance issues with this service and will be incrementally deploying fixes for it over the next few weeks.

Posted Aug 22, 2022 - 11:42 UTC

Resolved
Between 14:17 and 14:24 UTC today, a deployment and rollback of a service caused our dashboard to be unresponsive in our US-West-1 data center. In addition, Sauce Connect tunnels failed between 14:17 and 14:55.
Posted Aug 04, 2022 - 15:00 UTC