We are currently aware of an ongoing issue impacting the Talkback functionality on our Real Device Cloud. Our team is actively working to resolve this as quickly as possible.
Get email notifications whenever Sauce Labs creates, updates or resolves an incident.
Get text message notifications whenever Sauce Labs creates or resolves an incident.
Get incident updates and maintenance status messages in Slack.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 09, 2024 - 18:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Oct 29, 2024 - 23:33 UTC
Scheduled
Sauce Labs will have a two hour previously scheduled maintenance window on November 9th, starting at 18:00 UTC and ending at 20:00 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our US East and EU Central data centers. These maintenance actions may cause portions of the service (including running automated and manual tests) to be unavailable for up to two hours.
Posted Oct 11, 2024 - 23:40 UTC
This scheduled maintenance affected: Automated Virtual Mobile Device Testing (EU-Central), Automated Real Device Testing (EU-Central, US-East), Live Browser Testing (EU-Central), Live Virtual Mobile Device Testing (EU-Central), Live Real Device Testing (EU-Central, US-East), Insights (EU-Central), Billing (EU-Central), IPSec VPN (EU-Central), Native Framework Mobile App Testing (EU-Central, US-East), API Testing (EU-Central), Sauce Orchestrate (EU-Central), Automated Browser Testing (EU-Central), Sauce Connect (EU-Central, US-East), Sauce Labs REST API (EU-Central), and Sauce Labs Dashboard (EU-Central).