Sauce Labs Maintenance Windows for Sauce Labs
Customers may experience intermittent errors during automated browser and virtual mobile device tests in our US-West-1 datacenter. We are closely monitoring and investigating the affected services.
2023-April-21 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Friday April 21st 2023, 15:50 - 17:51 UTC

What happened:

Our virtual device capacity was slightly reduced for a specific macOS image due to a high volume of errors from a particular customer test targeting a faulty app running on iOS 15.4. The biggest impact was on that customer’s tests, but there was also a minor impact across the wider customer base, specifically slightly higher wait times for iOS 15.4 devices.

Why it happened:

The underlying issue is that there was a corrupted app file that was the target of a large volume of Appium tests resulting in test errors.

How we fixed it:

Our support team worked with the customer to upload a new app to address the issue. 

What we are doing to prevent it from happening again:

We are exploring ways we can enhance our app validation during the upload process.

Posted May 03, 2023 - 14:17 UTC

Resolved
After taking remedial action, iOS Simulators are back to normal and fully operational.
Posted Apr 21, 2023 - 18:10 UTC
Investigating
iOS simulator tests are receiving a high rate of errors upon session start. We are investigating.
Posted Apr 21, 2023 - 16:36 UTC
This incident affected: Automated Browser Testing (US-West), Automated Virtual Mobile Device Testing (US-West), Live Browser Testing (US-West), and Live Virtual Mobile Device Testing (US-West).