Our EU Central data center (RDC) will undergo unplanned but necessary power maintenance on June 19th, 2025, between 07:00 and 18:00 CEST (05:00–16:00 UTC).
During this maintenance window, devices may experience brief service interruptions lasting up to 20–30 minutes. We are taking every measure to minimize impact and ensure full service restoration as quickly as possible.
We appreciate your understanding and apologize for any inconvenience this may cause.
Get email notifications whenever Sauce Labs creates, updates or resolves an incident.
Get text message notifications whenever Sauce Labs creates or resolves an incident.
Get incident updates and maintenance status messages in Slack.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 19, 2025 - 05:00 UTC
Scheduled
Sauce Labs EU Central data center (RDC) will undergo unplanned but necessary power maintenance on June 19th, 2025, between 07:00 and 18:00 CEST (05:00–16:00 UTC). During this maintenance window, devices may experience brief service interruptions lasting up to 20–30 minutes. We are taking every measure to minimize impact and ensure full service restoration as quickly as possible. We appreciate your understanding and apologize for any inconvenience this may cause.
Posted Jun 18, 2025 - 18:09 UTC
This scheduled maintenance affected: Automated Real Device Testing (EU-Central), Live Real Device Testing (EU-Central), Native Framework Mobile App Testing (EU-Central), API Testing (EU-Central), and Sauce Labs REST API (EU-Central).