Sauce Labs will have a four hour previously scheduled maintenance window on Wednesday, July 10th, starting at 04:00 UTC and ending at 08:00 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our US West data center. These maintenance actions may cause portions of the service (including running automated and manual tests) to be unavailable for up to four hours.
Get email notifications whenever Sauce Labs creates, updates or resolves an incident.
Get text message notifications whenever Sauce Labs creates or resolves an incident.
Get incident updates and maintenance status messages in Slack.
After taking remedial action all services are operating as normal. This incident is resolved.
Posted Oct 30, 2024 - 21:52 UTC
Monitoring
We have taken remedial action and are seeing an improvement with Sauce Connect tunnel startup and allocation in the US-West-1 data center. We are monitoring
Posted Oct 30, 2024 - 20:53 UTC
Investigating
We are currently seeing intermittent issues with Sauce Connect tunnel startup and allocation in the US-West-1 data center. We are investigating.
Posted Oct 30, 2024 - 19:00 UTC
This incident affected: Automated Browser Testing (US-West), Automated Virtual Mobile Device Testing (US-West), Automated Real Device Testing (US-West), Live Browser Testing (US-West), Live Virtual Mobile Device Testing (US-West), Live Real Device Testing (US-West), API Testing (US-West), Sauce Connect (US-West), Visual Testing (Visual Testing Hub, Visual Testing Infrastructure), Native Framework Mobile App Testing (US-West), and Sauce Orchestrate (US-West).