Sauce Labs Maintenance Windows for Sauce Labs
Customers may experience intermittent errors during automated browser and virtual mobile device tests in our US-West-1 datacenter. We are closely monitoring and investigating the affected services.
2023-March-22 Resolved Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Wednesday March 22nd 2023, 09:30 - 10:24 UTC

What happened:

Customers may have experienced an elevated error rate when starting Android Emulator and iOS Simulator tests in US-West and EU-Central regions. 

Why it happened:

An application bug caused an issue assigning test requests to virtual device resources. This application bug was introduced during the revamp of the service responsible for this resource allocation. The main driver of the bug was an incorrect assumption of how the device specification is matched up and verified with the actual virtual device. The verification process differs when checking virtual desktop and mobile device specifications.

How we fixed it:

In order to restore service, we rolled back this code to the previous stable version.

What we are doing to prevent it from happening again:

We are increasing our integration testing and test case scenarios to ensure we capture these bugs before they hit production.

Posted Mar 28, 2023 - 15:50 UTC

Resolved
Between 09:30 and 10:30 UTC, customers may have experienced an elevated error rate when starting Android Emulator and iOS Simulator tests in our US-West and EU-Central data centers. We have identified and corrected the issue.
Posted Mar 22, 2023 - 10:30 UTC