Sauce Labs Maintenance Windows for Sauce Labs
We are currently performing maintenance that will affect the initiation of new Sauce Connect tunnel instances. The maintenance is expected to be completed by 2:00 PM PST. We appreciate your understanding and patience as we work to enhance our service.

2024-October-11 Resolved Service Incident 2

Incident Report for Sauce Labs

Postmortem

Dates:

Friday October 11th 2024, 09:19 - 19:19 UTC

What happened:

Real Device tests using Sauce Connect 5 tunnels experienced failures in all datacenters.

Why it happened:

An improperly tested change to Sauce Connect service was rolled out.

How we fixed it:

The sauce connect service was rolled back to a previously working version.

What we are doing to prevent it from happening again:

Fixes to post-deploy checks are planned to prevent this issue from reoccurring.

Posted Apr 01, 2025 - 16:03 UTC

Resolved

Between 9:33 and 19:21 UTC, Real Device tests running via Sauce Connect tunnel (version 5) experienced failures on US-West-1 and EU-Central-1 and US-East-4 Data centers. We have identified the issue and taken remedial action.
Posted Oct 11, 2024 - 19:26 UTC