Sauce Labs Maintenance Windows for Sauce Labs
We are currently performing maintenance that will affect the initiation of new Sauce Connect tunnel instances. The maintenance is expected to be completed by 2:00 PM PST. We appreciate your understanding and patience as we work to enhance our service.

2023-June-23 Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Friday June 23 2023, 12:15 - 13:18 UTC

What happened:

Customers experienced elevated start times and error rates for Windows, Mac, iOS Simulator, and Android Emulator tests in our EU-Central datacenter.

Why it happened:

Regular third-party maintenance rendered autoscaling services into an unhealthy state.

How we fixed it:

The autoscaling service was restarted.

What we are doing to prevent it from happening again:

Improving service auto-healing, both generally and for this specific failure mode.

Posted Jun 30, 2023 - 10:24 UTC

Resolved

After taking remedial action, all desktop and mobile device sessions are starting successfully in our EU-Central-1 data center. All services are fully operational.
Posted Jun 23, 2023 - 13:58 UTC

Investigating

Between 12:18 and 13:20 UTC, error rates for desktop and virtual mobile device tests were elevated in our EU-Central-1 data center. Error rates for Android emulator tests are still elevated. We are investigating.
Posted Jun 23, 2023 - 13:35 UTC
This incident affected: Automated Virtual Mobile Device Testing (EU-Central) and Live Virtual Mobile Device Testing (EU-Central).