Sauce Labs Maintenance Window
We are experiencing intermittent issues with iOS Simulators and MacOS desktop browser tests in our US-West data center, caused by a third-party service disruption. Our engineering team is actively coordinating with the provider to restore full service.

2025-September-3 Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Wednesday September 5th 2025, 13:50 UTC - 16:31 UTC

What happened:

The App Storage Service in the EU Central 1 data center experienced elevated response times, leading to timeout errors with uploading applications.

Why it happened:

The App Storage Service experienced connection issues with the backend.

How we fixed it:

The connection issues were resolved by restarting the affected application.

What we are doing to prevent it from happening again:

We have improved observability signals for the App Storage Service and implemented regular scheduled restarts of the application.

Posted Dec 11, 2025 - 16:09 UTC

Resolved

After taking remedial action, the app storage service has been restored in the EU Data Center. All services are fully operational.
Posted Sep 03, 2025 - 17:10 UTC

Investigating

We are currently seeing app storage upload issues in the EU datacenter. We are investigating.
Posted Sep 03, 2025 - 16:34 UTC
This incident affected: Automated Real Device Testing (EU-Central), Live Real Device Testing (EU-Central), and Native Framework Mobile App Testing (EU-Central).