Sauce Labs Maintenance Windows for Sauce Labs
Customers may experience intermittent errors during automated browser and virtual mobile device tests in our US-West-1 datacenter. We are closely monitoring and investigating the affected services.
2022-June-21 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Tuesday June 21th 2022, 12:14 - 13:20 UTC

What happened:

During that time real device espresso tests were not starting.

Why it happened:

A new API Gateway version was deployed that doesn’t handle properly gzip encoded payloads.

How we fixed it:

We deployed the latest stable version of API Gateway.

What we are doing to prevent it from happening again:

We are improving coverage of our API Gateway post deploy tests to include all supported configurations.

Posted Jul 26, 2022 - 17:21 UTC

Resolved
After taking remedial action, all tests using Saucectl are now running. This issue is now resolved, All services are fully operational.
Posted Jun 21, 2022 - 13:20 UTC
Identified
We have identified that this is affecting Real Device native framework tests run using versions of saucectl prior to 0.99.0. We are still working on resolving the issue, but upgrading to saucectl 0.99.0 or later (https://docs.saucelabs.com/dev/cli/saucectl/#updating-saucectl) should work around the issue.
Posted Jun 21, 2022 - 12:50 UTC
Investigating
In both our US-West and EU-Central datacenters, Real Device native framework tests run using saucectl are failing to start. We are investigating.
Posted Jun 21, 2022 - 12:21 UTC
This incident affected: Native Framework Mobile App Testing (US-West, EU-Central).