Sauce Labs Partially Degraded Service
We are currently experiencing a slight reduction in available public and private iOS devices in the EU-Central Data Center. We expect to restore full availability for all iOS users in the EU-Central Data Center by tomorrow, Thursday, July 3, 2025, end of day

2025-April-23 Resolved Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Wednesday April 23rd 2025, 16:50 UTC - 17:50 UTC

What happened:

Native Android tests failed in the EU-Central-1 datacenter.

Why it happened:

A large increase in simultaneous jobs with unique applications and cache misses, exhausted resources on the hosts responsible for installing Android native applications.

How we fixed it:

Resources were increased to cope with demand.

What we are doing to prevent it from happening again:

We have introduced additional controls on native application installs to prevent simultaneous downloads of the same app to a single host .

Posted Jun 13, 2025 - 10:38 UTC

Resolved

Between 16:55 - 17:25 UTC, we experienced Android Real Device Test failures in our EU data center. After taking remedial action, the issue has been resolved. All services are fully operational.
Posted Apr 23, 2025 - 17:42 UTC