Sauce Labs Maintenance Window
We are experiencing intermittent issues with iOS Simulators and MacOS desktop browser tests in our US-West data center, caused by a third-party service disruption. Our engineering team is actively coordinating with the provider to restore full service.

2026-January-5 Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Monday, January 5th 2026, 20:40 UTC - 21:04 UTC.

What happened:

There was a decrease in Real Device availability in the US-West-1 datacenter.

Why it happened:

During a planned traffic flow migration, a network policy applied to the new traffic path was more restrictive than intended and this resulted in a subset of Real Devices (~40%) failing to maintain required connectivity.

Although the change followed standard change management and peer review processes, the issue was not identified prior to activation.

How we fixed it:

The network policy was corrected and affected services recovered.

What we are doing to prevent it from happening again:

We are reviewing our network change processes to provide earlier detection of unintended behaviour during planned changes.

Posted Feb 20, 2026 - 11:05 UTC

Resolved

We were experiencing device unavailability in our private device cloud in the US data center and we have deployed a fix. This issue has been resolved. All services are fully operational.
Posted Jan 05, 2026 - 22:24 UTC

Monitoring

We have been experiencing device unavailability in our private device cloud in the US data center and have identified the root cause. We have deployed a fix and we are monitoring.
Posted Jan 05, 2026 - 21:15 UTC
This incident affected: Automated Real Device Testing (US-West) and Live Real Device Testing (US-West).