Sauce Labs Maintenance Windows for Sauce Labs
We are aware of and working to resolve intermittent WiFi connectivity and slowness issues affecting Android Real Devices in our US-West-1 data center. Please contact our Support team should you wish to report any such issues.

2021-September-14 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Tuesday September 14th 2021, 11:30 - 14:00 UTC

What happened:

Users were seeing sporadic errors while launching Real Device Live tests.

Why it happened:

We encountered an issue while integrating a new version of an internal Sauce Connect library into our Real Device Live Testing service, which caused the user’s live testing session to disconnect.

How we fixed it:

We rolled back to a previous version, which didn’t include the new library.

What we are doing to prevent it from happening again:

We are enhancing our automated testing to expand the coverage of our use cases.

Posted Sep 21, 2021 - 10:19 UTC

Resolved
All issues are resolved, the Real Device Live service is fully operational in all datacenters.
Posted Sep 14, 2021 - 14:01 UTC
Monitoring
We have taken remedial action for the Real Device Live service. We are monitoring.
Posted Sep 14, 2021 - 13:47 UTC
Investigating
Live Real Device tests in eu-central-1 are seeing sporadic errors while the session launches. We are investigating the Real Device service.
Posted Sep 14, 2021 - 12:47 UTC
This incident affected: Live Real Device Testing (US-West, EU-Central).