Sauce Labs Maintenance Window
We are aware of an ongoing issue preventing logins to App Distribution when using Single Sign-On (SSO). We are actively investigating..

2026-February-27 Service Incident

Incident Report for Sauce Labs

Resolved

After taking remedial action, we are now seeing real device test results display in the US-West-1 data center. All services are fully operational.
Posted Feb 27, 2026 - 20:15 UTC

Investigating

Live and automated real device test results are not being displayed on the test results page in the US-West-1 data center. We are investigating.
Posted Feb 27, 2026 - 18:42 UTC
This incident affected: Sauce Labs Dashboard (US-West).