Sauce Labs Maintenance Windows for Sauce Labs
We are aware of and working to resolve intermittent WiFi connectivity and slowness issues affecting Android Real Devices in our US-West-1 data center. During a maintenance window on September 25, we made changes to our wireless infrastructure which has greatly improved the situation, but we are still monitoring and working on further improvements. Please contact our Support team should you wish to report any such issues.

2021-October-27 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates:

Wednesday October 27th 2021, 21:04 - 21:59 UTC

What happened:

Both the Sauce Labs signup page and platform configurator returned 5xx errors. 

Why it happened:

A misconfiguration in a release prevented traffic being correctly served. 

How we fixed it:

The team resolved the issue by rolling back the problematic release. 

What we are doing to prevent it from happening again:

We added additional monitoring to find connectivity issues faster and we’re adding extra steps to the automated deployment process to prevent it from happening in future.

Posted Nov 03, 2021 - 18:47 UTC

Resolved
We have taken remedial action and are now seeing the sign up page and platform configurator load successfully. All services are fully operational.
Posted Oct 27, 2021 - 22:05 UTC
Investigating
Our sign up page and platform configurator are both displaying a 504 Gateway Timeout error. We are currently investigating.
Posted Oct 27, 2021 - 21:54 UTC
This incident affected: saucelabs.com.