Sauce Labs Partially Degraded Service
We are currently experiencing a slight reduction in available public and private iOS devices in the EU-Central Data Center. We expect to restore full availability for all iOS users in the EU-Central Data Center by tomorrow, Thursday, July 3, 2025, end of day

2025-June-13 Resolved Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Friday June 13th 2025, 07:47 UTC - 09:07 UTC

What happened:

A release impacted components of the Sauce Labs Web UI, making them unusable.

Why it happened:

Certain fonts were blocked from loading due to CORS issue.

How we fixed it:

The release was rolled back.

What we are doing to prevent it from happening again:

We are adding additional validation steps to prevent this from recurring.

Posted Jun 20, 2025 - 13:50 UTC

Resolved

Between 07:30 - 09:00 UTC, There was an issue with the Saucelabs Dashboard User Interface, this caused problems accessing apps and test results in the all datacenters. After remedial action this issue was resolved.
Posted Jun 13, 2025 - 06:30 UTC