Sauce Labs Partially Degraded Service
We are currently experiencing a slight reduction in available public and private iOS devices in the EU-Central Data Center. We expect to restore full availability for all iOS users in the EU-Central Data Center by tomorrow, Thursday, July 3, 2025, end of day

2025-June-18 Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Wednesday June 18th 2025, 11:04 UTC - 12:23 UTC

What happened:

The service responsible for App storage and retrieval experienced long response times.

Why it happened:

The App storage service was experiencing connectivity issues.

How we fixed it:

The connectivity issues disappeared before any remediation actions could be taken..

What we are doing to prevent it from happening again:

We have added tracing validations for the app storage service connectivity to give earlier visibility of any future occurrences.

Posted Jul 07, 2025 - 09:00 UTC

Resolved

After taking remedial action, the app storage service has been restored in the EU Data Center. All services are fully operational.
Posted Jun 18, 2025 - 12:54 UTC

Investigating

We are currently experiencing issues with our app storage service in the EU Data Center. We are investigating.
Posted Jun 18, 2025 - 11:53 UTC
This incident affected: Automated Virtual Mobile Device Testing (EU-Central), Automated Real Device Testing (EU-Central), Live Virtual Mobile Device Testing (EU-Central), Live Real Device Testing (EU-Central), and Sauce Labs REST API (EU-Central).