Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs will have a four hour previously scheduled maintenance window on Wednesday, July 10th, starting at 04:00 UTC and ending at 08:00 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our US West data center. These maintenance actions may cause portions of the service (including running automated and manual tests) to be unavailable for up to four hours.
2023-June-24 Service Incident 2
Incident Report for Sauce Labs
Postmortem
Posted Jul 11, 2023 - 10:27 UTC

Resolved
After taking remedial action, Windows Desktop sessions are starting successfully in our US-West-1 Data center and error rates are back to normal. All services are fully operational.
Posted Jun 24, 2023 - 03:02 UTC
Investigating
Windows tests are seeing elevated error rates in our US-West-1 Data center. We are investigating.
Posted Jun 24, 2023 - 02:11 UTC
This incident affected: Automated Browser Testing (US-West) and Live Browser Testing (US-West).