Sauce Labs Maintenance Window
Starting July 31, 2026, Sauce Labs will no longer accept traffic from Sauce Connect 4 . Customers must upgrade to Sauce Connect 5 to continue using Sauce Connect Proxy.

2026-June-18 Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Thursday June 18 2026, 03:45 UTC - 06:45 UTC.

What happened:

Approximately 7% of iOS devices in our EU data center were temporarily unavailable for customer test sessions after a loss of power to the rack hosting them.

Why it happened:

The power circuit feeding the affected rack exceeded its capacity, and a protective breaker tripped to safeguard the line - cutting power to the devices on that rack until the circuit was restored.

How we fixed it:

The affected circuit was reset and power restored to the rack, returning the devices to customer service.

What we are doing to prevent it from happening again:

We are redistributing power load across affected racks, adding capacity monitoring with early-warning alerts ahead of circuit limits, and introducing a capacity review before new devices are deployed to a rack.

Posted Jul 06, 2026 - 17:32 UTC

Resolved

After taking remedial action, we are now seeing real devices available for testing in the EU-Central-1 data center. All services are fully operational.
Posted Jun 18, 2026 - 06:59 UTC

Monitoring

We have been experiencing device unavailability in our EU-Central-1 data center and have identified the root cause. We have taken remedial action and are currently monitoring.
Posted Jun 18, 2026 - 06:12 UTC

Investigating

Around 3:51 AM UTC we started experiencing lower iOS device availability in the EU-Central data center. Our team is actively investigating the root cause and working toward a resolution.
Posted Jun 18, 2026 - 07:30 UTC
This incident affected: Automated Real Device Testing (EU-Central) and Live Real Device Testing (EU-Central).