Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs has consolidated onto one status page for all data centers.

The old status pages for US-West, US-East and EU-Central are still available to be able to view incident history. Anyone who was subscribed to notifications from one of the old status pages has been migrated onto this consolidated page. If you received an email saying that you had been unsubscribed from notifications, that was from one of the old pages and can be disregarded.

If you would like to select which components that you receive notifications for (e.g. if you are only interested in receiving notifications about incidents affecting Real Device Testing), you can access the subscription management page by clicking "Subscribe To Updates" above and enter the email address you are subscribed with. Additionally there is a "Manage Your Subscription" link on any email you will receive from the status page going forward.
2020-April-20 Service Incident
Incident Report for Sauce Labs
Postmortem

Dates

Tuesday April 20, 2021 18:19 - 21:54 UTC

What happened

Customers using Google or GitHub Sign-In options could not log into the Screener UI using those methods. Other sign-in options continued to function correctly.

Why it happened

The Google and GitHub Sign-In options in Screener are provided via a 3rd-party service, Auth0. Auth0 had a major outage, and our integration with them did not function.

How we fixed it

Auth0 fixed their outage, and functionality returned to normal. We also provided via the Sauce Status page alternative ways for users to sign into Screener.

What we are doing to prevent it from happening again

We plan to make monitoring improvements so that we are alerted earlier if this happens again, and we are able to notify customers earlier with alternative ways to sign-in to reduce user impact.

Posted Apr 22, 2021 - 00:43 UTC

Resolved
Auth0 has recovered and Screener login is now fully operational
Posted Apr 20, 2021 - 21:54 UTC
Update
Auth0 service continues to be down impacting Screener Signin through GitHub and Google. As an alternative, users can Sign in with email/password or MicroSoft or Sauce sign-in
Posted Apr 20, 2021 - 19:29 UTC
Investigating
Auth0 service is currently down preventing users from logging into Screener UI that uses Auth0 service. We are monitoring the status of dependent service https://status.auth0.com/ and will post an update once it is resolved
Posted Apr 20, 2021 - 18:19 UTC
This incident affected: Visual Testing (Screener) UI.