Sauce Labs Maintenance Windows for Sauce Labs
Our EU Central data center (RDC) will undergo unplanned but necessary power maintenance on June 19th, 2025, between 07:00 and 18:00 CEST (05:00–16:00 UTC). During this maintenance window, devices may experience brief service interruptions lasting up to 20–30 minutes. We are taking every measure to minimize impact and ensure full service restoration as quickly as possible. We appreciate your understanding and apologize for any inconvenience this may cause.

2025-June-16 Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Monday June 16th 2025, 12:25 UTC - 13:20 UTC

What happened:

Approximately 50% of RDC devices in the EU-Central-1 datacenter were unavailable.

Why it happened:

Maintenance on the datacenter power supply led to devices being shut down.

How we fixed it:

The affected devices were restarted.

What we are doing to prevent it from happening again:

We are looking to add more power redundancy and create established maintenance windows.

Posted Jun 20, 2025 - 08:20 UTC

Resolved

After taking remedial action, we are seeing normal availability levels of Real Devices in our EU-Central-1 datacenter. This incident is resolved.
Posted Jun 16, 2025 - 13:29 UTC

Investigating

We are currently experiencing reduced availability of Real Devices in our EU-Central-1 datacenter. We are investigating.
Posted Jun 16, 2025 - 12:49 UTC
This incident affected: Automated Real Device Testing (EU-Central), Live Real Device Testing (EU-Central), and Native Framework Mobile App Testing (EU-Central).