Sauce Labs Maintenance Window
We are experiencing intermittent issues with iOS Simulators and MacOS desktop browser tests in our US-West data center, caused by a third-party service disruption. Our engineering team is actively coordinating with the provider to restore full service.

2026-January-13 Service Incident

Incident Report for Sauce Labs

Postmortem

Dates:

Tuesday, January 13th 2025, 9:10 UTC - 10:37 UTC.

What happened:

The App Storage Service experienced high response times in the US-West-1 datacenter.

Why it happened:

Due to a high number of concurrent uploads, the App Storage Service experienced increased connection latency and delays in acquiring connections to the backend.

How we fixed it:

Service was restored by restarting the application.

What we are doing to prevent it from happening again:

We are improving monitoring, alerting and validations for the App Storage Service to backend connectivity. We are also evaluating how to handle periods of increased load and proactively detect performance degradation to implement automated remediation and self-healing capabilities.

Posted Feb 03, 2026 - 13:58 UTC

Resolved

After taking remedial action, the app storage service has been restored in the US-West-1 Data Center. All services are fully operational.
Posted Jan 13, 2026 - 10:50 UTC

Investigating

We are currently experiencing issues with our app storage service in the US-West-1 Data Center. We are investigating the issue.
Posted Jan 13, 2026 - 10:43 UTC
This incident affected: Automated Browser Testing (US-West), Automated Virtual Mobile Device Testing (US-West), Automated Real Device Testing (US-West), Live Browser Testing (US-West), Live Virtual Mobile Device Testing (US-West), Live Real Device Testing (US-West), and Native Framework Mobile App Testing (US-West).