Sauce Labs Maintenance Windows for Sauce Labs
Customers may experience intermittent errors during automated browser and virtual mobile device tests in our US-West-1 datacenter. We are closely monitoring and investigating the affected services.
2023-May 16 Service Incident 2
Incident Report for Sauce Labs
Postmortem
Posted Jun 02, 2023 - 18:09 UTC

Resolved
After taking remedial action, Real Device tests and Sauce Connect tunnels have returned to normal operation in our US-West-1 and EU-Central-1 Data Centers. This incident is resolved.
Posted May 16, 2023 - 12:19 UTC
Monitoring
After taking remedial action, Real Device tests and Sauce Connect tunnels are starting without issues in our US-West-1 and EU-Central-1 Data Centers. We are continuing to monitor.
Posted May 16, 2023 - 11:45 UTC
Investigating
We are seeing errors when starting Real Device tests and Sauce Connect tunnels in our US-West-1 and EU-Central-1 Data Centers. We are investigating.
Posted May 16, 2023 - 10:44 UTC
This incident affected: Automated Real Device Testing (US-West, EU-Central) and Sauce Connect (US-West, EU-Central).