2018-October-16 Service Incident
Incident Report for Sauce Labs Inc
Postmortem

Date: October 16, 2018
Time: 7:28 am - 8:45 am PDT

*What happened:
*
There was an increased failure rate for live and automated tests running on our U.S Real Device Cloud (RDC).

*Why it happened:
*
A surge in long-running tests caused excessive memory usage and degraded the quality of service for RDC in the U.S.

*How we fixed it:
*
We allocated additional resources for the U.S. RDC Service to ensure that the quality of service returned to normal levels.

*What we are doing to prevent it from happening again:
*
We are further optimizing our services so that they make more efficient use of memory.

Posted about 2 months ago. Oct 19, 2018 - 14:00 PDT

Resolved
This incident has been resolved.
Posted about 2 months ago. Oct 16, 2018 - 08:45 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 2 months ago. Oct 16, 2018 - 08:30 PDT
Investigating
We are investigating an elevated rate of automated test execution failures and Live test session disconnections in our US real device cloud.
Posted about 2 months ago. Oct 16, 2018 - 07:48 PDT
This incident affected: Manual Testing (Manual RDC Testing) and Automated RDC Testing (Automated RDC Testing, US Data Center).