Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs will have a four hour previously scheduled maintenance window on Wednesday, July 10th, starting at 04:00 UTC and ending at 08:00 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our US West data center. These maintenance actions may cause portions of the service (including running automated and manual tests) to be unavailable for up to four hours.
2023-May-8 Service Incident
Incident Report for Sauce Labs
Postmortem
Posted Jun 02, 2023 - 17:51 UTC

Resolved
We have taken corrective steps and are seeing all Real Device tests start successfully in the US-West-1 Data Center. All services are fully operational.
Posted May 08, 2023 - 22:11 UTC
Update
We continue to see intermittent start failures for Real Devices in the US-West-1 Data Center. We continue to investigate.
Posted May 08, 2023 - 17:57 UTC
Investigating
Android and iOS Real Device tests are failing to start intermittently on our US-West-1 Data Center. We are investigating.
Posted May 08, 2023 - 16:50 UTC
This incident affected: Automated Real Device Testing (US-West) and Live Real Device Testing (US-West).