Sauce Labs Maintenance Windows for Sauce Labs
Sauce Labs will have a four hour previously scheduled maintenance window on Wednesday, July 10th, starting at 04:00 UTC and ending at 08:00 UTC. During this maintenance window, we will be making updates to our infrastructure and services in our US West data center. These maintenance actions may cause portions of the service (including running automated and manual tests) to be unavailable for up to four hours.
2023-May-16 Service Incident (continued)
Incident Report for Sauce Labs
Postmortem
Posted Jun 02, 2023 - 18:07 UTC

Resolved
This incident has been resolved.
Posted May 16, 2023 - 08:34 UTC
Monitoring
We have taken corrective action. Sauce Connect tunnels are starting and tests and the dashboard are working without issues. We are continuing to monitor.
Posted May 16, 2023 - 08:14 UTC
Update
The Sauce Labs dashboard in our EU data center is also slow to load. We are investigating.
Posted May 16, 2023 - 07:15 UTC
Investigating
Customers are continuing to experience intermittent issues starting Sauce Connect tunnels and running tests using Sauce Connect tunnels in our EU-Central data center. We are investigating.
Posted May 16, 2023 - 07:08 UTC
This incident affected: Live Real Device Testing (EU-Central), Sauce Connect (EU-Central), and Sauce Labs Dashboard (EU-Central).