2018-07-10 Service Incident
Incident Report for Sauce Labs Inc
Resolved
This incident has been resolved.
Posted 2 months ago. Jul 10, 2018 - 06:48 PDT
Update
We are continuing to investigate this issue.
Posted 2 months ago. Jul 10, 2018 - 06:42 PDT
Investigating
Automated and manual RDC tests on US devices are not starting. We are investigating.
Posted 2 months ago. Jul 10, 2018 - 06:40 PDT
This incident affected: Automated RDC Testing (Automated RDC Testing, US Data Center) and Manual Testing (Manual RDC Testing).